[問題] arduino的spaceship LED不正常亮..

看板ASM (組合語言)作者 (苗栗小五郎)時間1年前 (), 1年前編輯推噓2(203)
留言5則, 3人參與, 1年前最新討論串1/1
試了幾次,最後成功了,附在最下面.. http://thats-worth.blogspot.com/2014/02/arduino-starter-kit-05-spaceship.html 我是按這篇的的程式碼作的 自己上網買了副廠版和麵包版插插看,也有用IDE上載了程式碼 但是並不照網址中的範例影片LED閃燈方式 我作的如下 https://www.youtube.com/watch?v=K0PtKmTt6xU
反而是手摸電阻時會有閃爍的現像 看起來不像是程式碼的問題,請問我那裡弄錯了,謝謝~ -- ※ 發信站: 批踢踢實業坊(ptt.cc), 來自: 111.251.123.87 (臺灣) ※ 文章網址: https://www.ptt.cc/bbs/ASM/M.1591266855.A.839.html

06/04 21:22, 1年前 , 1F
如果代碼沒有改,就是電路沒接好
06/04 21:22, 1F
補充,順序有改,第一LED和第三LED對調,

06/04 23:12, 1年前 , 2F
我猜紅線壞了,黃色LED插反
06/04 23:12, 2F

06/04 23:14, 1年前 , 3F
建議你買其他模組前,先買個三用電錶
06/04 23:14, 3F
我再檢查了一下,把紅線換掉, 黃LED應是沒插反,也沒壞,因為把黃和紅的LED對調, 再試一次還是這樣 至於電路沒接好 這是我一開始用擴展板和小麵包的情形 https://www.youtube.com/watch?v=4v7vTvTepbM
這是正常的 後來綠燈被玩壞了,現在才改用黃燈 我並不是一接上不會亮就上來問 因為一開始買套件的時候,就買進階版,只有擴展板和小麵包 但一堆初階範例都用大麵包,只好再去買大麵包 結果大麵包怎麼插都不正常亮.. 有兩塊大麵包, 測試結果都是這樣,該不會是都壞了? 有沒其他可能性? ※ 編輯: sorrows (111.251.123.87 臺灣), 06/05/2020 00:02:22 通通拔掉,再試一次,程試碼也再重傳一次 https://www.youtube.com/watch?v=AXWV74fU1fQ
現在只有黃燈亮了,怎麼回事呢? ※ 編輯: sorrows (111.251.123.87 臺灣), 06/05/2020 00:34:10 我再改成大麵包附的電線 https://www.youtube.com/watch?v=ltSwkpBtjT0
LED燈號反過來了 黃燈還會微閃^^" 可以幫我找一下原因嗎?我不想這樣亂跳, 不然我沒辦法預期進入下個project的情形,會難以學習啊... ※ 編輯: sorrows (111.251.123.87 臺灣), 06/05/2020 02:17:23 把麵包板反過來再插一次 這次成功了 https://www.youtube.com/watch?v=aXqAgJdKnHA
希望有人可以告訴我,之前那有問題, 現在為什麼又可以了,謝謝^^" ※ 編輯: sorrows (111.251.123.87 臺灣), 06/05/2020 02:36:17

06/05 13:02, 1年前 , 4F
看看麵包板後面是不是斷了,把雙面泡綿膠輕輕撕下來看
06/05 13:02, 4F

06/15 00:39, 1年前 , 5F
你有試過把腳位宣告給隔開嗎?
06/15 00:39, 5F
文章代碼(AID): #1UsCudWv (ASM)
文章代碼(AID): #1UsCudWv (ASM)