[問題] json server安裝失敗

看板Web_Design作者 (AnnyCat)時間7月前 (), 編輯推噓2(201)
留言3則, 2人參與, 7月前最新討論串1/1
按照這個影片安裝json sever時,出現了一些安裝錯誤,請問這個要怎麼解決呢? https://youtu.be/R8GL5y49iJc?t=1229
PS E:\visualweb\git-repos\web-05> npm install -g json-server C:\Program Files\nodejs\json-server -> C:\Program Files\nodejs\node_modules\json-server\lib\cli\bin.js npm WARN notsup Unsupported engine for nanoid@3.2.0: wanted: {"node":"^10 || ^12 || ^13.7 || ^14 || >=15.0.1"} (current: {"node":"13.6.0","npm":"6.13.4"}) npm WARN notsup Not compatible with your version of node/npm: nanoid@3.2.0 + json-server@0.17.0 不知道是不是又win7的問題,更之前也是安裝最新node無法使用,找好久才找到是 版本問題。 -- ※ 發信站: 批踢踢實業坊(ptt.cc), 來自: 114.41.55.74 (臺灣) ※ 文章網址: https://www.ptt.cc/bbs/Web_Design/M.1643869324.A.412.html

02/03 18:02, 7月前 , 1F
錯誤訊息看起來是 node 版本問題
02/03 18:02, 1F

02/04 19:07, 7月前 , 2F
你的 node 版本是 13.6.0, 該套件要求若 node 是 13 版要.7
02/04 19:07, 2F

02/04 19:08, 7月前 , 3F
然後, 最新的 node 並不是 13 版喔, 現在的 LTS 是 16.13.2
02/04 19:08, 3F
文章代碼(AID): #1X-tICGI (Web_Design)
文章代碼(AID): #1X-tICGI (Web_Design)